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Introduction 

Protein Metrics applications have common Reporting features: 

• Review all plots on the same page through the Plot Tab. 

• Export the report into PDF, Microsoft Excel workbook, or CSV (common separated values) 
format. 

• Perform further data analysis through the Pivot Table. 

• Organize project information into a Summary. 

• Reuse the report design saved as a template on future data sets. 

• Time-saving – Reports are automatically generated through Byos workflows. 

This manual will focus on reporting capabilities of the Byos suite of applications (mainly Peptide Analysis, 
Intact Analysis, and Chromatogram Analysis). 

Data Flow 

When the user creates a report, application data is passed into the Report Module as a Flat Input Table. 
The Flat Input Table is a table of rows and columns, similar to the CSV format or an Excel worksheet. The 
user can add Dynamic Columns to further analyze data through the Pivot Tables. A simplified diagram 
detailing the data flow is shown below: 

 

Figure 1: Data flow module for report generation 
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Creating Reports 

To create a report, select File > Export > Report or simply click the report icon  below the Help menu. 

 

Figure 2: Generating a report from the project File menu 

A report opens with tabs defined by the default report template as shown in Figure 3 and Figure 4: 

 

Figure 3: A default report. 

In the legacy products, the report opens in a separate window. By toggling over the legacy product icon in 
the task bar, the user can select to view the project or associated report. 
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Figure 4: A default report template from Byos 

In Byos, the report opens as an additional tab to right of the associated project. All default Byos workflows 
contain a report template specifically designed to support that type of analysis. This is included in the 
Processing nodes > Report section.   

 

Figure 5: Set the report configuration in the Processing nodes tab during project creation 

For details about the report template, see the Report Template and Default Report Template section. 

To create a report based on data in multiple projects, please refer to the Multi-Document Report section. 

File > Export > Fixed Excel report (legacy) exports the project to an Excel file in the same way that File 
> Export > Export to Excel workbook exports from within a report. 

Report Menu Overview 

Menu Sub Menu Action and Notes 

File Load from File Load a Report Template from the file system and create the tabs as 
defined in the Report Template. This action replaces all current tabs. 

  Save to File Save current tabs into a Report Template. 

  Save to Document Save current report as associated with the current analysis. When 
the project is next opened, the saved report will be attached to the 
associated file.   

  Export Export all or part of the report as PDF, Excel workbook, images, or 
CSV. Refer to the Export section for additional details. 
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  Preset Load predefined Report Template, Tab Template, or Dynamic 
Columns. Refer to the Preset section for additional details. 

  Close Close the Report. 

     

Edit Current Tab Settings Tab configuration settings. Refer to each tab section for additional 
details. 

  Edit dynamic column Add, edit, or delete a dynamic column. Refer to the Dynamic Column 
section for additional details. 

  Copy pivot table to 
clipboard 

Enabled for the Pivot tab only. Pivot table content is copied to the 
clipboard as tab separated values. 

     

Tabs  Add pivot table Add a pivot table tab. Refer to the Pivot Tab section for additional 
details. 

  Add summary Add summary tab. Refer to the Summary Tab section for additional 
details. 

  Add plots Add plot tab. Refer to the Plot Tab section for additional details. 

  Add flat input table Add a tab displaying the contents of the flat input table. The flat input 
table tab can be added only once. This option can be of use to 
examine the data that goes into the Report Module. 

  Duplicate current tab Make a copy of the current tab. The flat input table cannot be 
duplicated. 

  Update tab content Application changes, such as column filtering, will be updated and 
reflected in all Report tabs. 

Report File Menu 

The File sub-menu contains various options to process reports: 

 

Figure 6: File Menus 

Load from file loads in a previously saved report template and updates the report accordingly. Save to 
file saves the current report template format. Save to document attaches the generated report to the 
associated project. 

File > Export includes five sub-menu items: 
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Figure 7: File > Export menus 

Export to PDF generates a .pdf document version of the report: 

 

Figure 8: Export to PDF settings 

The Export to PDF settings includes: 

• Export options to choose to export all tabs, only plots, or all tabs except plots. 

• Page settings to set page margins, visibility and placement of page numbers, page orientation 
(Auto uses a combination of portrait and landscape as suits each tab), and total document width. 

• Image compression level to set the image resolution quality, and thus, size of the exported file. 
The higher the compression, the smaller the size but the lower the image quality. 

Export to Excel workbook generates a *.xlsx file of all tabs. The PTM Summary tab, charts and plots are 
rendered as images, while pivot tables are rendered as spreadsheets.  
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Figure 9: Export to Excel workbook settings 

Export to image generates one *.png file for each of the tabs. Export to pivot table content (CSV) writes 
the pivot table to a *.csv file. Export input content as flat file (CSV) writes a pivot table to a flattened *.csv 
file (common values are repeated for all pivoted fields). Export XY data from traces (CSV) exports the 
underlying XY data used to create the trace plot. 

File > Presets refers to files that configure report formats: 

 

Figure 10: File > Presets menus 

Post pivot columns and Pre pivot columns presets load columns into the pivot tables. Report presets 
lists the default report templates provided to support different types of projects. The list is different when 
opening a *.blgc, *.ntms, and *.bmap project type. Tab presets loads additional default tab types into an 
existing report. For more information, see the section Report and Tab Templates. 

Close closes the report without closing the project. However, closing the Project will also automatically 
close the associated Report. 

Report Edit Menu 

The Edit menu contains three sub-menus: 

 

Figure 11: Edit menus 

Current tab settings allow edits on certain tab properties; each tab type has a different set of properties 
that can be edited. See the sections on the tab types for the kinds of edits allowed through the Current tab 
settings dialog. 

Edit dynamic columns allows the editing, addition, or removal of pivoted dynamic columns: 
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Figure 12: Edit dynamic columns for Peptide Analysis project report 

Click the   icon to edit the displayed name. Click the   icon to delete the pivot field. Click the Add new 
column button to add another pivot field. Click the Finish and reload button to reload these edits. Please 
contact support@proteinmetrics.com for support working with dynamic columns.  

Copy pivot table to clipboard copies the pivot table data as tab separated values. 

Report Tabs Menu 

The Tabs sub-menus add additional tabs to an existing report: 

 

Figure 13: Tabs menus 

Add pivot table adds a new Pivot tab that can be edited using Edit > Edit dynamic columns. Add 
summary adds a new Summary tab that defaults to the same format as the Summary tab included in many 
reports. Add plots adds a new Plots tab (as well as File > Presets > Tab presets > Bmap_Plots) that 
creates a report of all the project plot types. Add flat table input adds a new Flat Table Input tab that 
contains data in many fields as a flattened pivot table. Right-click the header to see a list of available fields; 
uncheck the checkboxes to hide unneeded field columns.  

Duplicate current tab makes a copy of the selected tab with the same name; this can be useful to explore 
altered layouts and displayed data fields. Please note the duplicated tab will appear at the very end of the 
set of tabs in the current report (to the far right). The user can simply drag the tab to the desired location. 
Double click the tab name to insert a cursor for editing. 

Update tab content updates all the report tabs based on any new changes made to the project. Changes 
to the project are not automatically reflected to the report.    

mailto:support@proteinmetrics.com
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Report Toolbar 

 

Figure 14: Report toolbar 

The Show configuration button displays the available pivot fields and all rendering and aggregation 
options for the tab (for Pivot tabs only). When pressed again, these configuration options are hidden (to 
make printed or exported reports more condensed, for example). The configuration settings are still 
displayed in the report footer at the bottom left of the tab. 

Copy pivot table to clipboard copies the pivot table data as tab separated values. 

Find locates all occurrences of an entered text string within the current tab: 

 

Figure 15: Find function 

Report and Tab Templates  

A report template, with *.rptc extension, contains the tabs and configurations, as well as both pre- and post-
pivot dynamic columns, for the generated report. When generating a new report from an application, a 
default report template, with the name appended with “(Default)”, is read from installed configurations. Other 
useful configurations are available in the same directories. To load a non-default report configuration file 
from within a report, choose File > Presets > Report presets.  

Users can also add new Pivot and Plot tabs to existing reports. There are a number of default tab templates 
available for Pivot and Plot tabs. To load a new tab from within a report, choose File > Presets > Tab 
presets.  

Peptide Analysis contains the following report templates available in File > Presets > Report presets: 
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Figure 16: Peptide Analysis report templates 

Peptide Analysis contains the following tab templates available in File > Presets > Tab presets: 

 

Figure 17: Peptide Analysis tab templates 
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Intact Analysis contains the following report templates available in File > Presets > Report presets: 

 

Figure 18: Intact Analysis report templates 

Intact Analysis contains the following tab templates available in File > Presets > Tab presets: 

 

Figure 19: Intact Analysis tab templates 

Chromatogram Analysis contains the following report templates available in File > Presets > Report presets:  

 

Figure 20: Chromatogram Analysis report templates 

Chromatogram Analysis contains the following tab templates available in File > Presets > Tab presets: 
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Figure 21: Chromatogram Analysis tab templates 

Oligo Analysis contains the following report templates available in File > Presets > Report presets:  

 

Figure 22: Oligo Analysis tab templates 

Once a report has been modified, a report configuration file can be saved and used by another project. To 
save a report template, select File > Save to file. To load a custom report template, select File > Load 
from file, navigate to the directory and file containing the report configuration file, and click Open. 

A custom report configuration file can be set to be the updated default report template loaded with a new 
report. The new default report template must be named a specific way and the old default report template 
renamed so it is no longer loaded. To create a new default report template: 

• For Peptide Analysis, add (Default) at the end of the *.rptc filename to create a default report. For 
example, Blgc_Std_PTM Report(Default).rptc.  
Paste the file into the directory: \Program Files\ProteinMetrics\PMI-
Suite\Base\presets\Byologic\report_config.  
Rename the file Blgc_PTM (Default).rptc so that it is no longer a default report template. These 
actions require administrator privileges.  

• For Chromatogram Analysis, add (Comparison_Default) or (Reference_Default) at the end of the 
*.rptc filename to create a default report template for comparison or reference projects.. Paste the 
file into the directory: \Program Files\ProteinMetrics\PMI-
Suite\Base\presets\Byomap\report_config. Rename the file Bmap (Comparison_Default).rptc or 
Bmap (Reference_Default).rptc so they are no longer the default report templates.  

• For Intact Analysis, add (ComparisonDefault) or (ReferenceDefault) at the end of the *.rptc 
filename to create a default report template for comparison or reference projects. Paste the file 
into the directory: \Program Files\ProteinMetrics\PMI-Suite\Base\presets\Intact\report_config. 
Rename the file Intact_Mass_Pivot_Report (ComparisonDefault).rptc or 
Intact_Mass_Pivot_Report_withPlots (ReferenceDefault).rptc so they are no longer the default 
report templates. 

Report Tab Management 

The user can add Summary, Pivot Table, Plot, or Flat Input Tables as tabs in the Report. 

To add a tab, select the Tab menu and select either Add pivot table, Add summary, Add plots, or Add 
flat table input. 

The user can add a custom logo to a report tab by dragging and dropping an image onto a report tab. The 
customized image will be placed at the top left corner. The customization will apply to all tabs. 

To remove the customized image, hover over the image until a red X appears at the top right corner of the 
image. Click on the red X to remove the image from all tabs.  
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Figure 23: Customizing the report logo 

To rename a tab, double click the tab name to insert a cursor for editing. 

To remove the tab, click on the black X to the right of the tab name. 

Summary Tab 

The Summary Tab includes some of the important table data from the project. An example Summary Tab 
from a peptide analysis appears as follows: 

 

Figure 24: Summary tab 

To edit the Summary Tab, select Edit > Current tab settings: 
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Figure 25: Editing the Summary tab in Current tab settings 

Current tab settings for the Summary tab have three sections: 

• General options contains Color code sample name which color codes the Project table text 
with the sample colors. 

 

Figure 26: Project table in Summary tab color-coded by sample name 

• Project table options determines which columns are displayed in the report Project table. The 
user may choose between pre-defined table columns, all table columns (primarily applicable to 
Intact Analysis), and customized columns. When Show customized columns is selected, the 
Edit columns button appears. 
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Figure 27: Current tab settings with Show customized columns selected 

To edit the visibility and order of columns in the Project table, click the Edit columns button. 

 

Figure 28: Setting Project table column visibility and order in the Summary tab 

To remove a column from the Project table, uncheck the column name. To reorder a Project table 
column, click the column, drag it to the new position, and release it. 

• Font options allows the user to adjust the size, weight (Normal or Bold), style (Normal or Italic), 
name and color of the font. An example of the formatted text is displayed in the dialog. 

Advanced users can further edit the Summary tab by clicking the Edit summary template button to open 
the Template Editor:  
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Figure 29: Summary tab template editor 

See the Summary Tab Template Editor section for additional details. 

Pivot Tab 

According to Wikipedia: 

A pivot table is a table of statistics that summarizes the data of a more extensive table (such as from a 
database, spreadsheet, or business intelligence program). This summary might include sums, averages, 
or other statistics, which the pivot table groups together in a meaningful way. 

Pivot tables are a technique in data processing. They enable users to arrange and rearrange (or "pivot") 
statistics in order to draw attention to useful information. By grouping hierarchical data (with one-to-many 
relationships) under multiple column headings, complex data can be organized and condensed into a 
simpler table. 

For example, the data in the flat table in the figure below displays across 64 rows: 
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Figure 30: Flattened table data 

The same data can be reorganized in a much more intelligible structure using a pivot table, as show in the 
figure below: 

 

Figure 31: Pivoted table data 

In the above example, the fields “Sample Name” and “Peak” were dragged above the table to create two 
levels of pivoting. The numeric field “Delta mass from calc.” is removed from the field list in the left column, 
and instead is selected in the drop-down at top left. The “Delta mass from calc.” field is now displayed for 
the combination of the pair of row fields “Name” and “Expected mass” and the pair of column fields “Sample 
Name” and “Peak”. 
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Tour of Pivot Table Areas  

 

Figure 32: The regions in a Pivot Table 

1. View type 

2. Aggregator options 

3. Show unused fields 

4. Show row fields 

5. Show column fields 

6. Show row total 

7. Show column total 

Rendering Options 

Pivoted data is not limited to tables; a variety of charts and plots can display pivoted data. To change the 
data display type (rendering option), click the drop-down option at the top-left: 
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   Figure 33: Pivot tab rendering options 

Category Rendering Options Current tab settings and notes 

Chart Area Chart, Bar 
Chart, Horizontal Bar 
Chart, Horizontal 
Stacked Bar Chart, 
Line Chart, Pie 
Chart, Protein Map, 
Scatter Chart, 
Stacked Bar Chart, 
Table Barchart 

Common settings and Chart-specific settings. 

Line Chart also has an option to Show R2, slope and intercept 
values. 

Error 
Chart 

Error Bar Chart, Error 
Line Chart 

Common settings and Error Chart settings. 

Error Chart is enabled only if the post-pivot dynamic column 
AllErrorColumns or StdDevErrorColumns are added into the Pivot 
Table. 

Heatmap Col Heatmap, 
Heatmap, Row 
Heatmap 

Common settings and Color settings. 

Col/Row Heatmap defines the color range based on values within 
each column/row. Heatmap will consider all values of columns and 
rows. 

PCA PCA  Common settings and PCA-specific settings. 

Protein 
3D 

Protein 3D Common settings and protein 3D-specific settings. 

Treemap Treemap Common settings only. 

Venn 
Diagram 

VennDiagram Common settings and Chart-specific settings. 

 

Aggregator Options 

Aggregators are the statistical method used to display sets of pivoted numeric data. To change the 
aggregator, click the drop-down option to the right of the rendering option: 



Reporting Manual v5.11   

21 
 

 

Figure 34: Pivot tab Aggregator options 

Aggregator Description 

Average Displays average values. 

Count Displays number of values. This function does not require a parameter. 

Integer Sum Displays summed values for integers. 

Maximum/Minimum Displays maximum or minimum values. 

Normalize Column/Row Displays normalized values by column or row. 

  
To normalize based on a specific value other than Sum or Max of all 
values in a column (or row), select Custom. Normalize By field will list all 
eligible fields. Normalize By value will list all values of the selected field. 
Level defines the pivot level to normalize against. Level 0 normalizes to the 
selected value. Level 1 and 2 normalizes by the first or second field values, 
respectively. 

Sum Display summed values. 

Sum as Fraction of 
Total 

Display summed value as a percentage of all values in column/row/table. 

Sum over Sum For example: Mn = Sum(intensity*mass)/Sum(intensity). 

 

Field Management 

To change the numeric data field to pivot, click the drop-down option below the aggregate method: 
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Figure 35: Data field to select for the pivoting 

To add a new field to the table, click the field name from the available fields in the first column, and drag it 
to the desired order of the displayed fields in the second column. To reorder a table field column, click the 
field name in the second list, and drag it to the new order position: 

 

Figure 36: Drag-and-drop new fields into the table 

To add a new field to the pivoted value columns, click the field name from the available fields in the first 
column, and drag it to the desired order of the pivot fields above the table: 

 

Figure 37: Drag-and-drop new fields into the pivoting 

The pivot table editing as in the Figure above updates to reflect the new layer of pivoting shown in the 
Figure below: 

 

Figure 38: Pivoted results after the table edit 
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Filters 

Data values can be filtered from the report in two ways. Include/Exclude filters, where unchecked values 
are removed from the report and from all aggregate calculations, can be set for pivot row and column fields, 
but also for unused fields. Show/Hide filters, where unchecked values are not removed from aggregate 
calculations, but they are not displayed in the report, can be set for pivot row and column fields. The user 
can only Show or Hide values that are included in a pivot tab. A value that is excluded from the report will 
be disabled from Show/Hide selection. To open the filters, click the down arrow following the field name. 
Both filter types will open: 

 

Figure 39: Included/Exclude and Show/Hide Data filters 

Click Select All to check all unique values and Select None to uncheck all values. If any values are 
unchecked, the pivot field name is moved to the top of the field list and is marked in red with an exclude 

filter   or a hide filter  icon, as shown in Figure 40 below. 

 

Figure 40: Filtered data is marked in red and shown with filter type icons 

For numeric data, the filters apply to the aggregator calculation. Unchecked Include/Exclude filter values 
are excluded from the calculation, while unchecked Show/Hide filter values are included in the calculation: 
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Figure 41: Filtering data from the aggregator calculation 

To modify the data format for either the pivot column or pivot row fields, set the Significant figures or Decimal 
place to be displayed. Note the displayed data format does not change the calculation result for aggregator 
values. 

To filter by string values or numeric ranges, select Contains for string values or a numeric operator. Then 
enter the string or numeric value: 

 

Figure 42: Text filters using operators 

The available list of values updates as the value is typed in: 

 

Figure 43: Numeric filters using operators 
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To reorder how the values of a pivot field is displayed, set Type of filters to Custom order, and drag and 
drop the values to reorder them. Reordering does not affect the aggregation calculation: 

 

Figure 44: Reordering labels by drag-and-drop 

Pivoted data can also be filtered inside the pivot table directly. To filter from within the pivot table, right-click 
the lower-level pivot field to open the filter dialog: 

 

Figure 45: Filtering data in the pivot table through a right-click in the second pivot level 

Sorting 

To sort data in the display fields, click once to sort ascending (down arrow), twice to sort descending (down 
arrow), and a third time to remove the sort (no arrow): 
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Figure 46: Table sorting 

Show/Hide Configuration 

When the report tab is fully configured, the configuration controls can be hidden to maximize the display of 
the data. To hide the data and field configuration controls, click the selected Show configuration button 
at the top left: 

 

Figure 47: Hide Configuration mode 
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Pivot Tab Current Tab Settings: Common 

To edit the Pivot Tab itself, select Edit > Current tab settings: 

 

Figure 48: Pivot options in Current tab settings 

Setting Description 

Number formatting Options are Significant figures and Decimal places.  

Significant figures Significant figures range is 1 to 10. 

Decimal place Decimal place range is 0 to 10. 

Number format Options are Numeric, Scientific, Percent, or ppm. 

Pivot table settings   

Max number of values 
in filters menu 

Used to limit the number of pivot field values. If there are n values, and n-m 
is set as max, the last/maximum m values are not displayed. 

Show column totals Displays the totals of all the column values within rows at different levels of 
pivoting in a column to the right of the table. Level 0 displays a single total 
for all rows. The highest level displays a total for each table row. The 
allowed range is 1 to the number of pivot column (or row) fields + 1.  

Show row totals Displays the totals of all the row values within columns at different levels of 
pivoting in a row at the bottom of the table. Level 0 displays a single total for 
all columns. The highest level displays a total for each table column. The 
allowed range is 1 to the number of pivot column (or row) fields + 1.  

Show unused fields Turns off display of the first column containing the unassigned row fields. 

Show column fields Turns off display of the pivot fields above the table. 

Show row fields Turns off display of the second column containing the assigned row fields. 

Show report details When “Show configuration” is unpressed, (set to “Hide configuration 
mode”), pivot table aggregation and filtering information are displayed at the 
bottom of the report. See Figure 48 and Figure 49.  
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Show all pivot fields or 
Show all common pivot 
fields 

Show all pivot fields – show all fields which comes from the input flat table. 
Show all common pivot fields – show fields which are listed in 
commonly_used_column_names.ccnson (which is in the application specific 
presets folder, for example, Program Files > ProteinMetrics > PMI-Suite > 
Base > presets > Byologic) as well as all pre pivot dynamic columns. 

 

 

Figure 49: Show configuration with Show report details unchecked 

 

Figure 50: Same pivot table with Show configuration turned off and with Show report details checked. 
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Text can be added to the top or bottom of the Pivot tab, and text font in the tables can be formatted: 

  

Figure 51: Modified residue rendering and Free text settings in Current tab settings 

To mark modified residues as red and/or underlined in the report, the user must check Mark as red and/or 
Mark as underlined in the Modified residue rendering options settings (figure above). 

To add free text to the pivot tab, select whether to add the text at the start of end of the tab, then click Edit 
free text. Enter the free text and click OK. 

A pop-up window appears with options to change the font, justify text, and add bullets to the text.  

  

Figure 52: Edit Text at the end settings 

Adjust the size, weight (Normal or Bold), style (Normal or Italic), name and color of the font and click OK. 
In the figure above, the text “Crosslink reporter peaks:” is added. In addition to the free text, images can be 
added in the window as well. Users can drag-and-drop an image into the free text in a report. 
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Figure 53: A sample histogram image and free text added to the text box 

Pivot Tab Current Tab Settings: Chart specific 

 

Figure 54: Pivot chart options in Current tab settings  
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Setting Description 

Pivot table 
settings  

Data axis By default, the row is the X-axis. Sometimes the user wants to switch row and 
column. If column is selected, column values will be used on the X-axis and row 
values on Y-axis. 

Chart settings   

Font size of axis Font size between 1 and 20. 

Label orientation To avoid label collision or for better readability, the user can place the label at an 
angle. The angle range is -90 to 90 degrees. 

Show R2, slope 
and intercept  

(Line Chart only) 

When checked, R2 values, slopes and intercepts are displayed on the top right of 

the chart in the format y = mx + b: 

 

Auto resize chart 
to window 

When checked, the chart will fit within the display screen adjusting for Show 
configuration (Show unused fields or Show row fields). When unchecked, the 
chart will fit within the specified width and height pixel settings. 

Grid lines When checked, the chart will display grid lines at the axis values. 

Custom y range When checked, the chart will be plotted on the specified minimum and maximum 
Y axis range.  

Numeric X-axis (Except Pie chart and Table Barchart) - When checked, displays numeric labels 
on the X-axis 

Color settings  

Color  Colors are assigned to the column field values. Colors in charts default to a 
pastel palette. To change a color, enter a new RGB value or click the value to 
display a color chooser. Please note values can be copied and pasted to apply 
the same color to multiple components, if desired. 

  

Connect the dots (Scatter charts only) - When checked, connects the plotted points with line 
segments 
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X-, Y-axis Log 
scale 

(Line charts and Scatter charts only) - When checked, displays and labels that 
axis data with a logarithmic scale 

 

 

Figure 55: Default colors from a high-contrast palette 

 

Figure 56: Horizontal bar chart with high-contrast color palette 
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Pivot Tab Current Tab Settings: Modification specific 

 

Figure 57: Filtering Pivot tables by modifications 

Pivot tables can be filtered by individual modifications (e.g., oxidation, deamidation), or combinations of 
modifications. Modification filters include the corresponding wildtypes. All peptides is checked by default. 
To filter by one or more modification, check Filtering by modifications, uncheck All peptides, and check 
the modifications to include. For example, the settings above produce a table like this: 

 

 

Figure 58: A pivot table filtered by glycosylation-only 
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Pivot Tab Heatmap  

Heatmaps are colored according to the values of the field set by the Color by option: 

 

Figure 59: Color by settings for heatmap views 

The Current tab settings dialog for heatmaps contains color settings: 

 

Figure 60: Standard color setting for heatmaps 

The Standard heatmap is checked by default. This heatmap setting colors table cells from light gray for 
the minimum values to dark blue for the maximum values. To change the color, enter a new RGB value or 
click the value to display a color chooser. Values can be copied and pasted to apply the same color to 
multiple components, if desired. 

The user has more color options when Standard heatmap is unchecked: 

 

Figure 61: Advanced heatmap color settings 

The minimum value color changes to red, and it is editable. Specific minimum or maximum values can be 
assigned by unchecking Use data min or max and entering those values. 

The Color range count represents the number of color gradations between the two color ranges. To create 
a gradual shift in color across values, use the maximum value, 255. To create distinct colors for a set of like 
ranges of values, use a much smaller count. The total range will be divided into bins by the color count and 
values in those bins will be given those distinct colors. 

file:///C:/Users/Jim/Desktop/Jim's/Business/Protein%20Metrics/Report%20Manual/_images/reporting_image27.png
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Use an absolute min/max applies the larger of the maximum and the absolute value of the negative 
minimum value as the range, thereby maintaining zero at its center. 

The color by feature allows intermediate colors. To add an intermediate color range, click Add color. The 
dialog updates to show an added intermediate color: 

 

Figure 62: Heatmap color settings with an intermediate color 

Two different color ranges are defined with an intermediate color value. This value is midway between the 
minimum and maximum values. This value and the default color can be edited, as above. Additional 

intermediate colors can be inserted with the Add color button. Click  after an intermediate color to delete 
it. The same intermediate color can be used to create a range of values with the same color, to deemphasize 
some of the data. For example, consider the setting:  

 

Figure 63: Heatmap with a range of data marked in white 
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This setting results in following heatmap: 

 

Figure 64: The heatmap resulting from the settings in the Figure above. 

Default value color is assigned to values that are beyond the range of set minimum and maximum values, 
or to cells without values.  

A new Value out of range Label is introduced to label the feature values that fall out of a customized range. 
The standard heatmap settings can be customized for a certain range. To change the settings, choose Edit 
> Current tab settings and uncheck Standard heatmap. The user has an option to enter a custom value 
for threshold i.e., uncheck Use data min and enter a cut-off to highlight values below the cut-off. Similarly, 
to highlight values above a defined value, uncheck Use data max and enter a cut-off to highlight values 
above the cut-off. The user can annotate using custom color and text fields. In the below Figure, values < 
5 % are highlighted using the Use data min with a setting of 4.99. This results in all intensities less than 5 
% to have “<5%” in table/heatmap view (highlighted in cyan boxes). “<5%” is just an example text, any 
custom text can be used for this label. 

 

Figure 65: Labels to denote out of range values 

Pivot Tab Error Charts 

To create an error chart, add error columns to the pivot table. To add error columns, do the following: 

1. Select Presets > Post pivot columns > AllErrorColumns.postpvtjs, RSDErrorColumns.postpvtjs, or 
StdDevErrorColumns.postpvtjs: 
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Figure 66: Creating columns for error charts 

2. Enter a name for the error column and click OK. 

The Render options Error Bar Chart and Error Line Chart are now enabled. When either of these is 
selected, error bars are displayed on the charts: 

 

Figure 67: Formatted error line chart 

The Current tab settings dialog for error charts contains the Error column name option: 

 

Figure 68: Error column name setting 
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• StdDevErrorColumns - the error values are based on standard deviation. The Error column 
name is assigned to error:abs:stdDev 

• AllErrorColumns - the error values are based on the minimum or maximum value. Choose Error 
column name: error:abs:lower or error:abs:upper. 

Note that the column name such as errors:abs:stdDev is defined in the pivot JavaScript, which can be 
customized. 

Pivot Tab Principal Component Analysis (PCA) Plots 

A PCA view plots across a biosimilar experiment.  

 

Figure 69: PCA plot 

The Current tab settings dialog for PCA plots contains the following options:  

 

Figure 70: PCA options in Current tab settings 
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Setting Description 

Color settings  

Color  Colors are assigned to Sample Name values. To change a color, enter a new 
RGB value or click the value to display a color chooser.  

PCA settings  

Data entries By default, the row is X-axis/loading plot, and the column is Y-axis/data. 
Sometimes the user wants to switch the row and column. If column is 
selected, column values will be used on the X-axis and row values on the Y-
axis. 

Select component Specify eigenvalues used to show in the plot. These are sorted from highest 
to lowest rank. By default, component 1 (the highest) and component 2 (the 
second highest) are selected. 

Show axis Turns on or off the display of the X and Y axis. 

Auto detect range When checked, the X and Y range is defined by the data set. When 
unchecked, the X and Y range is set to the specified values.  

Show data labels Turns on or off the display of the data point labels. 

Label offset Label offset can be used to avoid label collision. 

Syntax: {“data label”:[x-offset, y-offset]} 

For example: 

{“labelsOffset”:[ 

{“-Trioxidation/47.9847”:[-150,0]}, 

{“-Dioxidation/31.9898”:[0,15]} 

]} 

Note that the X and Y offset are from the label’s original location of [0, 0]. 

Exact label name needs to be used. 

Pivot Tab Pie Chart 

Pie charts are now supported in Reports, with an option to create a single or multiple pie charts. To create 
a Pie Chart:  

1. Select File > Export > Report to open a report. 

2. In the Report window, select Tabs > Add pivot table. A new tab is created but not selected. 

3. In the Pivot Table tab, choose Pie Chart as the rendering option. The window updates with new 
report options and a default Pie Chart pops up.  

 

Figure 71: Pie chart settings 
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4. The pivots can be used to filter the data. To simplify the Pie Chart, few combinations of Mod. 
Names are selected. This results in a Pie Chart which is basically slices of a circle, the area of 
which explains the numeric proportion of the post-translational and other modifications present in 
a sample of interest: 

 

Figure 72: Pie Chart of different modifications present in the sample 

5. To generate multiple pie charts, click Edit > Current tab settings. Under the Chart Settings, 
enable the checkbox Display a separate pie chart for each field value and select the Field 
value of interest to generate multiple pie charts (Digest End Peptide is the field selected in 
below image). 

 

Figure 73: Chart settings within Current tab settings 

6. The above setting will result in many pie charts, and a snippet of which is shown in the figure 
below: 

 

Figure 74: Pie Chart showing proportion of modifications for different Digest End options 
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Pivot Tab Protein 3D Plots 

Protein 3D Visualization is now supported in Reports, using the three-dimensional structure of the Protein 
Data Bank (PDB). To create a protein 3D visualization: 

1. Select File > Export > Report to open a report. 

2. In the Report window, select Tabs > Add pivot table. A new tab is created but not selected. 

3. In the Pivot Table tab, choose Protein 3D as the rendering option (the top left drop-down arrow). 
The window updates with new report options: 

 

Figure 75: Protein 3D settings 

4. For PDB, select the desired protein database *.pdb file: 

 

Figure 76: Setting the PDB file 

The *.pdb files are found in Program Files\ProteinMetrics\PMI-
Suite\Base\html\protein3DCoreFiles \protein_3d_files. To include a custom protein database file, 
in this drop-down list, copy the file to the above directory.  

5. For Color by, select the desired sample name (each replicate of each sample are options). The 
pivot column fields will be mapped to the Color by field options. Each column can map to a chain 
in the PDB. 

6. For Index, select the pivot row field. The pivot row fields will be mapped to the Index field options. 
The PDB file can contain multiple chains and amino acids in the sequence of each chain can be 
accessed through the residue number. 

7. Choose the desired statistical method (the default is Sum) and the desired pivot field (the default 
is XIC Ratio%). The 3D version of the structure is displayed:   
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Figure 77: 3D depiction of a protein 

To rotate the 3D structure around the horizontal axis, depress the left-click button and move the cursor up 
and down. To rotate the 3D structure around the vertical axis, depress the left-click button and move the 
cursor right and left. 

By default, only one chain is color mapped. To configure color mapping of additional PDB chains: 

1. In the Report, select Edit > Current tab settings. 

 

Figure 78: Protein 3D chain configuration 



Reporting Manual v5.11   

43 
 

2. At the bottom, click Add chain configuration:  

 

Figure 79: Add chain configuration dialog 

3. Use the drop-down arrow to select the Chain name. 

4. For the Chain field, select all values or select single value and choose a value from the drop-
down. Optionally, set a Position offset value for the chain. 

5. By default, the first color applies to the dataset minimum. To set a specific minimum value, 
uncheck Use data min and enter the number under Value. To change the color for the minimum 
value, click the Color cell and select a new color as the low end of the color range. The color in 
the cell will update. Repeat as needed for the Maximum row. 

6. The Color range count represents the number of color gradations between the two color ranges. 
To create a gradual shift in color across values, use the maximum value, 255. To create distinct 
colors for a set of like ranges of values, use a much smaller value. The total range will be divided 
into bins by the color count and values in those bins will be given those distinct colors. 

7. An absolute range uses the larger of the absolute value of a negative minimum and the maximum 
value as the negative minimum value and the positive maximum value. To apply this absolute 
range, check Use an absolute min/max. 

8. The color by feature allows intermediate colors. To add an intermediate color range, click Add 
color. The dialog updates to show an added intermediate color: 
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Figure 80: An intermediate color added to the color range 

Two different color ranges are defined with intermediate value. This value is midway between the 
minimum and maximum. This value and the default color can be edited, as above. Additional 

intermediate colors can be inserted with the Add color button. Click  after an intermediate color 
to delete it. 

9. Value out of range color is assigned to values that are beyond the range of set minimum and 
maximum values. By default, this is white. The Value undefined color is assigned to locations 
without values. By default, this is black. These colors can also be edited. Use this color 
assignment to give the protein a backbone color.  

10. Click the OK button. The structure in the report updates with the color-by chain settings: 

 

Figure 81: 3D Protein colored by chain 
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11. To edit the color range for a chain in the Current tab settings dialog, click the  icon in the 
corresponding row and repeat the steps listed above. The dialog updates with the new minimum 
and maximum colors: 

 

Figure 82: Chain color bar settings 

Pivot Tab Treemap Diagram 

According to Wikipedia: 

Treemaps display hierarchical (tree-structured) data as a set of nested rectangles. Each branch of the tree 
is given a rectangle, which is then tiled with smaller rectangles representing sub-branches. 

1. Select File > Export > Report to open a report (if the Report tab is not open). 

2. In the Report window, select Tabs > Add pivot table. A new tab is created but not selected. 

3. In the Pivot Table tab, choose Treemap as the rendering option. The window updates with new 
report options and a default Treemap pops up. The pivots used can be filtered accordingly on the 
sample name and/or the feature name. Below is an example of Treemap showing the post-
translational and other modifications present in a sample of interest: 

 

Figure 83: Treemap view of modifications present in a sample 

Pivot Tab Venn Diagram 

1. Select File > Export > Report to open a report (if the Report tab is not open). 

2. In the Report window, select Tabs > Add pivot table. A new tab is created but not selected. 

3. In the Pivot Table tab, choose Venn Diagram as the rendering option. The window updates with 
new report options and a default Venn diagram pops up. 

4. It is critical to set the fields in pivots appropriately and to limit the number of comparisons made 
i.e., Compare across sets of samples, charge states. In the below figure, MS Id - MS Alias name 
are used to denote the sets: 

https://en.wikipedia.org/wiki/Tree_(data_structure)
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Figure 84: Venn diagram of 3 sets comparing the overlap of modification types 

5. The number of sets used can be filtered out by using Include/Exclude and Show/Hide option. In 
the below figure, MS Alias name is filtered to exclude out “WT” from the Venn Diagram 
visualization: 

 

Figure 85: Filtering sets to be seen in the Venn diagram 

6. The names of the sets in this Venn diagram are 1-Day1, 2-Day3 and 3-Day7, representing MS Id 
and MS Alias name. To rename the sets to Day1, Day3 and Day7 (i.e., MS Alias name), remove 
the MS Id pivot and the Venn Diagrams updates as shown below: 

 

Figure 86: Updated Venn diagram with adjusted sample names (i.e., Day1, Day3, Day7) 

7. To increase the font size and to change the colors of the sets, click Edit > Current tab settings, 
edit Font size of axis (under Chart settings) and edit colors (under Color settings) as shown in 
the figure below resulting in the Venn Diagram with an improved font size and different colors for 
the 3 sets. 
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Figure 87: Improved label names and updated colors 

Pivot Tab Volcano Plot 

1. Select File > Export > Report to open a report (if the Report tab is not open). 

2. In the Report window, select Tabs > Add pivot table. A new tab is created but not selected. 

3. In the Pivot Table tab, choose Volcano Plot as the rendering option. The window updates with 
new report options and a default Volcano plot pops up. 

4. It is critical to set the fields in pivots appropriately to get a meaningful volcano plot: 

 

Figure 88: Volcano plot 

5. To change the threshold limits of fold change and p-value, select Edit > Current tab settings 
and update the Significance threshold and log2 fold change threshold values. The 
Reference columns and Test columns for generating the volcano plot can be either selected 
directly inside pivot tab (shown in above figure) or the user has an option to update these 
columns within the Edit > Current tab settings dialog (shown in below figure). 



Reporting Manual v5.11   

48 
 

 

Figure 89: Filtering settings of volcano plot 

Pivot Tab Protein Map 

Protein Maps are found in the Blgc_HDX.rptc report template used by the HDX workflow: 

 

Figure 90: Protein map 

The Protein Map creates a visualization of individual segments based on the Y-axis setting for the Uptake 
plot (percent deuteration, center of m/z shift, or center of mass shift). Note that the pivot tabs included in 
the Blgc_HDX.rptc allow for the display of sequence letters instead of, or in addition to residue positions. 
The Current tab settings dialog for these tabs includes the Residue option setting: 

 

Figure 91: Residue option for Position or Sequence letter 
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The Residue option is also available for pivot tables that have applied the MHCVisualization.postpvtjs 
post-pivot processing. 

Plots Tab 

To create a Plots tab, select Tabs > Add plots. Each of the plots in the report will be assembled into a 
single tab, prefaced with identifying and quantifying data: 

 

Figure 92: Example Plots tab 

Plots Tab Current Tab Settings 

To configure the Plots tab, choose Edit > Current tab settings: 
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Figure 93: Plots tab Current tab settings 

Setting Description 

Plots visibility   

Show Whole 
trace plot  

 Displays the entire elution as the first plot: 

 

Show Divided 
trace plot  

Displays the elution into a series of relevant sections. These additional sections are 

set in the elution plots, using the Add plot segment  icon. 

Show Stacked 
Plots 

Displays the selected traces as stacked plots (for Intact, the user should select 
multiple traces in Trace Peaks table): 
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Font options Adjust the size, weight (Normal or Bold), style (Normal or Italic), name and color of 
the font. An example of the formatted text is displayed in the dialog. 

Export to PDF  

Page break after 
each row 

When checked, this inserts a page break after each row in exports to PDF. 

Plot options  

Resize plots When unchecked, the image will be cached by size, by default to a size that 
accommodates three plots per row. When checked, the image resolution is adjusted 
when the user designates counts of one or two images per row. To edit the images 
counts per row, click the Edit plot template button. Example plot assignments are 
shown below: 

 
The string [PlotXIC][PlotIsopte][PlotMS2] designates those plots in that order, three to 
a row. To separate these into two plots on one row, and third plot on the next row, 
move the third plot to the following line: 
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This produces the layout: 

 
One plot per row provides the best plot resolution with a tradeoff of largest plot file 
size and longer retrieval times. Three plots per row provides the most economic 
resolution and retrieval time. Two plots per row is in between. 

Plot scaling The default value for Plot scaling is 100%, but the user has an option to decrease this 
value (for example, 50%) to see more smaller sized plots in the same page area, or 
increase this value (for example, 200%) to see enlarged plots (see figure below). Left 
figure is the original size, middle figure is with Plot scaling set to 50% and right figure 
is the Plot scaling set to 200%. This can be used in combination with Resize plots for 
improving the display of multiple graphs. 

 

 

Display only 
zoomed-in 
segments 

Displays zoomed-in segments of the project. When unchecked, entire plots are 
displayed. 

 
For IntaBio plots (created from the IntaBio icIEF-MS workflow), the Plots tab in the report template 
Intact_IntaBio.rptc can be displayed or turned off using units of isoelectric point (pI) or minutes, and for 
whole or divided trace plots: 
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Figure 94: Setting units of pI or Minutes for whole or divided IntaBio plots 

Note: Plots are cached during an application session. If plot loading is cancelled, only the retrieved plots 
will be displayed. Loading of un-cached plots will continue when the Plot tab is refreshed either when the 
Plot tab becomes the current tab or Update tab is selected from the content menu. If all three plot sizes are 
cached, changing the plot layout will not cause a re-fetching of plots. 

Plots Tab Sorting 

To change the sort order of the plots, click the Edit plot sort button: 

 

Figure 95: Plot sorting 

The table displays the order of sorting by field value and direction. The sorting proceeds by the first field, 
followed by subsequent fields, as applicable. To change the Sort by direction, click the arrow beside the 

value and select the new direction. To delete a field for sorting, click the  icon. To rearrange the field 
sorting order, drag the field to the new order: 

 

Figure 96: Adjust sorting by drag-and-drop 

To add a new field to sort by, click the Add new sort button: 
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Figure 97: Add new sort type 

Select the Sort rows by field, select the Sort type direction, and then click OK. The new field is appended 
to the end of the sort list. 

When all sort edits are completed in the Sort order information dialog, click the Finish and reload button. 

Plots Tab Filtering 

The Show/Hide configuration mode is enabled for Plot tabs. This allows filtering of plots by the exposed 
fields, much the way Pivot tables are filtered: 
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Figure 98: Show configuration for Plots tab to filter the plots by field values 

Plots Tab Template Editor 

The headers and values displayed with the plots can be customized. To edit the headers in the Plots Tab, 
choose Edit > Current tab settings and click the Edit plot template button to open the Template Editor 
dialog:  

 

Figure 99: Plot data labels for Peptide Analysis projects 

For Peptide Analysis projects ( *.blgc ), the plots are prefaced with primary data. The data labels correspond 
to the following Peptides table field names: 

Label Field Name 

Sample  MS alias name 

Sequence Sequence (unformatted 

Mods Mod. Names 

z z 

Score Score 

XIC Area XIC AUC 

XIC % Mod XIC Ratio% 

Expected m/z Calc. m/z 

Obs m/z Obs. m/z 

Error (ppm) ppm 

Retention Time (min) Apex Time (Posit) 

InSilico status In silico 

 
For more information about this dialog, see the Template Editor and Short Codes section below. 

Template Editor and Short Codes 

The Template Editor allows a user to customize a tab using HTML tags and predefined Short Codes.  

The following section uses the Summary Tab as an example. Even though Short Code content might differ 
between applications or tabs, Preview and Short Code usages are the same among the Report tabs. 
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Summary Tab Template Editor 

To open the Template Editor from the Summary Tab, select Edit > Current tab settings, and click the Edit 
summary template button: 

 

Figure 100: Summary tab Template Editor 

The Edit menu contains the functions Undo, Redo, Cut, Copy, Paste. These same functions are also 
available as the first five toolbar buttons. 

Format menu contains the function Short Codes. This function is also available as a toolbar button by that 
name. 

The Preview toolbar button displays the label text (without HTML tags) as it would appear in the report tab. 

In the editor itself, terms in square brackets are reserved Short Codes. Text in angle brackets (<>) are 
standard HTML tags. All other text is displayed either in line or above Short Codes, as formatted.  

Summary Tab Short Code Reference 

Short Code Description 

All Applications  

[ByosProjectCreationOptions] Byonic search parameters used to create projects in Byos 

[PublicByosProjectCreationOptions] Byos Project Creation content excluding sample file names and 
sequences (often confidential)  

[File Path] Project document file path. 

[Date] Project document file creation date. 
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[Time] Project document file creation time. 

[User] Project creator. 

[Sequences] Sequence text. 

[ColumnFilters] Applied Peptide column filter. 

[MS file paths] Original and edited MS file paths (changed by Edit > Adjust MS 
paths) 

[ProjectCreations] Project Creation settings. The values are preset to display 6 
significant figures:  

(Note that the types of values vary by application.) 

Peak smoothing width (TIC) 

Baseline smoothing width (TIC) 

Peak tolerance max (TIC) 

Peak tolerance min (TIC) 

Baseline minimum angle (TIC) 

Baseline maximum angle (TIC) 

Baseline push tolerance (TIC) 

Blur Skewness 

[ProjectOptionsTable] Summary Project Table. 

[ProteinTable] Summary Protein Table. 

[LoginUserName] Current windows login user. 

[ProteinCoverageImage filter = 
“filtername”] 

Protein Coverage summary and percent values for the proteins 
filtered by a saved table (Peptides, Peaks, Trace Peaks) filter 

[ProteinCoverageImage] Protein Coverage image from the application. Fragment 
coverage is based on application settings. 

[FragmentProteinCoverageImage] Display protein and fragmentation coverage simultaneously. 

[SoftwareVersionProjectCreation] Version of the Protein Metrics Inc. application when project is 
created 

[SoftwareVersionReportGeneration] Version of the Protein Metrics Inc. application when report is 
generated 

Peptide Analysis Only  

[MS2Files] Imported MS2 ( *.byrslt ) files. 

[DataFiles] Raw source data files. 

[PeptideFilters] Applied Peptide filters. 

[ModificationFilters] Applied Modification filters. 

[ByonicSearchParameters] All parameters saved within the *.byparms file (including Fixed 
and variable modifications, Glycan modifications, Byonic 
parameters, etc. 

Chromatogram Analysis and Intact 
Analysis Only 

 

[ProjectFiles] Raw source files. 

[FilterOptions] Peak filtering settings. 

The following values are preset to display 6 significant figures: 

Lock Mass (m/z) 

Interest time end 

Interest time start 



Reporting Manual v5.11   

58 
 

[DeltaMass] Delta Mass values for named masses. 

[ProjectOptions] Project Settings. 
 

Note: Protein Coverage can be filtered and saved, and then the filtered view can be displayed in the 

Summary tab. To save a Protein Coverage filter, click the  icon above the Peptides table, add the filter 
rows, choose Presets > Save to document > Save with new name, add a name, and click OK twice: 

 

Figure 101: Saving a Protein Coverage filter in the Peptides table 

To load the filter into the report Summary tab, choose Edit > Current tab settings, click Edit summary 
template, add a line to place the filtered Protein Coverage image, and click Short codes. An additional 
item named for the saved filter appears for ProteinCoverageImage. Click Insert and click OK to add the 
filtered Protein Coverage: 

 

Figure 102: The Short Code generated for the saved Protein Coverage filter 

Summary Tab and Plot Tab Short Codes 

The Summary tab Short Codes for Peptide Analysis, Chromatogram Analysis, and Intact Analysis are as 
follows: 
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     Figure 103: Short Codes for Peptide Analysis, Chromatogram Analysis & Intact Analysis.      

Note: Short Codes can be searched by entering a string in the Text filter box. 
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The Plot tab Short Codes for Peptide Analysis are as follows: 

  

Figure 104: Peptide Analysis Plots tab Short Codes, part 1 
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Figure 105: Peptide Analysis Plots tab Short Codes, part 2 
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Figure 106: Peptide Analysis Plots tab Short Codes, part 3  
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The Plot tab Short Codes for Chromatogram Analysis are as follows: 

  

Figure 107: Chromatogram Analysis Plots tab Short Codes, part 1 
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Figure 108: Chromatogram Analysis Plots tab Short Codes, part 2 

  



Reporting Manual v5.11   

65 
 

The Plot tab Short Codes for Intact Analysis are as follows: 

 

  

Figure 109: Intact Analysis Plots tab Short Codes, part 1 
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Figure 110: Intact Analysis Plots tab Short Codes, part 2 

Dynamic Columns: Pre-Pivot and Post-Pivot JavaScript 

The user can use JavaScript to add Dynamic Columns to the input file that is used to create a pivot table. 

Pre Pivot JavaScript (.prepvtjs) can be added to all tabs or just the current tab. 

Per Tab Pre Pivot JavaScript (.prepvtjs) applies to the current tab only, and is identified with a superscript 
T following the field name. 
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Figure 111: Per tab Pre Pivot fields identified with “T”  

Post Pivot JavaScript (.postpvtjs) applies to the current tab only. 

To add Pre Pivot JavaScript, choose File > Presets > Pre pivot columns and select the column name to 
add.  

To add Post Pivot JavaScript, select Presets > Post pivot columns and select the column name to add. 

Pre Pivot JavaScript Reference 

Pre Pivot JavaScript Description 

All Applications  

DAR Calculates drug-to-antibody ratio by using the formula: intensity 
* DrugCount / (sum of intensities). 

DigestEnzymeSummary Summarize the enzyme digestion to fit known nomenclature. 

DisulfideLinkedPeptides Report the Base protein (Start AA – End AA) and Partner 
protein (Start AA – End AA) in disulfide linkage reporting 

DrugCount_Intensity Creates a column of drug value multiplied by intensity, where 
drug value comes from the string in the parenthesis in "Drug()" 
from the "Delta name" column. 

DrugsCount Creates a column with the drug count value, which comes from 
the string in the parenthesis in "Drug()" in the “Delta name" 
column. 

GlycanFamily Returns "1" if the peptide has a glycan or if the peptide 
sequence matches a peptide with a glycan. For example, both 
EEQYN[+1444.5]STYR and EEQYNSTYR (wildtype) return 1. 

GlycanShortname Creates a column of glycan short names (such as G0F, etc), 
determined by the glycan mass. 
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IsCTerm Creates a Yes/No column which identifies if the peptide contains 
the protein c-terminus residue. 

IsDeamOrOxOrPyro Creates a column which identifies if the peptide contains 
deamidation, pyrolization or oxidation; otherwise displays “No”. 

IsSVmod Creates a column of SV values if the peptide has a sequence 
variant modification (if Mod. Names contains the -> indicator); 
otherwise, it is blank. 

ModType Creates a column identifying the row as "Modified" or "Wildtype" 

ProteinNameStartEndPeptideLabel Creates a column which prefixes AA as a heavy chain or light 
chain, or if neither, the first letter of the protein name. 

RenameCols Provides the means to easily rename a column header in the 
report 

SeparateReplicates Searches for a substring of the form "r()" in the column MS Alias 
name and creates a column with the string inside the 
parenthesis. 

SeparateSamples Searches for a substring of the form "s()" in column MS Alias 
name and creates a column with the string inside the 
parenthesis. 

XlinkType Creates a column identifying the modification as “Disulfide” or 
“Trisulfide”. 

UpdateXlinkPartnerPeptideProteinName Replaces Xlink Partner Peptide Protein Name with Protein 
name if Xlink Partner Peptide Protein Name is (self). 

Peptide Analysis and Chromatogram 
Analysis 

 

ProteinCols Parses the Protein Summary content into separate columns. 

Peptide Analysis Only  

ADCQuant Uses cleaved wildtype peptides for ADC quantification of lysine-
conjugated linker drugs. 

AvgValues Creates four columns: [Avg Obs M], [Avg Obs m/z], [Avg ppm], 
and [Avg RT], which average the range or list of values in the 
respective columns. 

CDRLocationInfo Reports the modification status within complementarity 
determining regions (CDRs) of the antibody. 

ChargeRankGlyco Creates a column to display the most abundant charge state for 
each glycopeptide. 

ChargeRankWildType Creates a column to display the order of charge state 
abundance of the peptide. If the peptide is modified, returns the 
order of charge state abundance of the corresponding wildtype. 
This column can be filtered to easily set up a single-charge state 
peptide/PTM quantification. 

ChargeStatesCalculation Like AvgValues, except it also averages the values across 
different charge states. 

DigestSummary Creates a summary of protein digestion based on start/end 
peptide, n-term/c-term offsets, and accession name. 

DisulfideLocationMult Creates a dynamic column to allow the grouping of disulfide 
containing peptides by Cys location. 

GlycanGroupings.prepvtjs Creates a column including glycan group identities  

GlycanCartoon.prepvtjs Displays the glycans on glycopeptides. 
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IsoDmodname Overrides the Mod Names column if Label contains “iso”. 

LessThanThreePeptides Determines if a peptide belongs to a protein that has less than 
three peptides identified. This is useful for proteomics or host 
cell protein analysis. 

MinError Enables the user to report their best ppm (closest to zero) to 
assess instrument accuracy and aid in validation strategy.  

NGlycanFamily Detects if the specified row has an N-glycan or the peptide 
sequence matches a peptide with N-glycan, and returns the N-
glycan location 

NumberOfPeptides Determines the number of peptides that belong to a protein. 

PeakEval Warns if a modification is a possible artifact, i.e., in source 
oxidation, off-by-x, poor recovery, or low scoring. This filter 
looks at metrics gathered from the flat table. For poor recovery, 
a distribution of XICs is calculated and all wildtype peptides in 
the bottom two percentile are listed as poor recovery. If a 
modification shares similar retention time to its wildtype, it is 
flagged as an ESI artifact. 

PeptideLength Creates a column to display the number of amino acids in the 
peptide. Useful for filtering out small peptides. 

PeptideRanking Creates a column to display the rank of peptides based on their 
XIC AUC across charge states and per each protein. The user 
can filter peptide ranks of 1, 2, and 3 for “Top-3 quant”. 

PrefixSum Creates prefix sum of XIC ratio values 

ProteinAccession Parses Uniprot formatted protein headers and creates three 
columns with this information. 

QuantifyingGlycation Creates a column that groups wildtype peptides to quantify 
glycations by tryptic digests. 

SPQuantifier Creates a column to display if a peptide contains part of the n-
terminus for signal peptide quantification. 

SVA Creates a column to classify sequence variants into possible 
“true/false positive” and “check manually” categories. This filter 
first checks retention time differences and whether the 
sequence variant makes sense relative to the digestion, and 
then looks for low scores, high AUC, and whether the sequence 
variant can be explained by a more common adjacent 
modification like oxidation. The peptide will be labeled “check 
manually” if it fails one of these checks. All others are labeled as 
“true positive”. 

SeparateReplicates Creates different columns or rows based on different replicates 

SeparateSamples Creates different columns or rows based on different samples 

ScoresThresholding Filters out peptide identifications with a score below 100 and a 
Delta Mod score below 10. 

UniprotProteinName [deprecated] Creates an accession name column based on 
uniprotformatted protein name. 

WildcardCluster Clusters wildcard identification by their fractional mass, i.e. 
10.23 and 10.24 will be clustered into 10.2. 

XicAreaSummedIsoXNormalized Creates a column for formalized XIC area summed for peptides 
that contain deamidation alongside other modifications. The XIC 
area summed may be calculated using different isotopes for the 
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deamidated peptide (monoisotope) and the other modifications 
(determined by MS extract options table). The new column 
normalizes XICs by using the formula:  XIC area summed * XIC 
ratio / (1 - XIC Ratio). 

Chromatogram Analysis Only  

PPMMassError Computes ppm error, as a function of Observed m/z and 
Calculated m/z. 

PrefixSum Displays a running total of Start times (?) 

Intact Analysis Only  

GenericTokenExtract Creates new columns for each label found in a specified column 
(default "SamplesName"). A label is in the form "label(value)", 
an alphanumeric name, followed by a value within parentheses. 
The new column header is assigned the name and the value of 
the string within the parentheses. In the example above, the 
“label” header would contain “value” in its cell. 

PPMMassError Converts “Delta Mass from Calculated” values from Da to ppm 
units. 

ThresholdedDeltaMassDa Creates a column that displays 1 if the “Delta Mass from 
Calculated” value in Daltons is above a pre-defined threshold, 
and 0 if it does not. This can be used as a heatmap to highlight 
out of range masses. 

Post Pivot JavaScript Reference 

Post Pivot JavaScript Description 

All Applications  

AllErrorColumns Creates all error columns and enables error bar charts 
and error line charts 

RegressionLinear Add the linear regression analysis data to show 
intercept, r2 (indicating R2) and slope columns 

RSDErrorColumns Creates relative standard deviation column and enables 
error bar charts and error line charts 

StdDevErrorColumns Creates standard deviation column and enables error bar 
charts and error line charts 

TotalGroup Supports subtotal columns based on a pivot table row 
field 

Peptide Analysis Only  

HdxVisualization Supports the HDX Visualization view for HDX projects 

MHCVisualization Supports MHC reports 

MaxFoldChangeRow 

Finds the maximum fold change between a reference file 
and each of the non-reference files. The calculation 
applies to normalized columns 

NormalizedPPM 
Calculates "normalized ppm", using the formula: value / 
max * 1,000,000 

PvalueBetweenEachSampleAndControlSample Calculates p-value and all other helper values from t-test 
between control and each sample 

PValueFpopExperimentFocused Calculates p-value and all other helper values from t-test 
between two groups of values 
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Intact Analysis Only  

BranchDiffrence 
Creates a column to display the difference of two of the 
first columns 

ExtendPivotTable Extends pivot data cells by creating new Mass columns 

Editing Pre or Post Pivot JavaScript  

To edit Pre or Post Pivot JavaScript, select Edit > Edit dynamic columns followed by the JavaScript type: 

 

Figure 112: Editing pre pivot dynamic functions 

To edit the JavaScript for a dynamic column, click the  icon. To delete a dynamic column, click the  
icon. To add a new dynamic column, click the Add new column button, click the gray drop-down box at 
the lower left, and select the column field file to add: 

 

Figure 113: Adding a column as a pre pivot function 
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The drop-down at bottom left selects from the standard JavaScript functions. The Browse button allows 
the user to load a custom JavaScript function. The dialog loads the JavaScript written for that dynamic 
column: 

 

Figure 114: Pre pivot JavaScript 

Tour of JavaScript Add New Column Dialog  

 

Figure 115: JavaScript areas in the Add new column dialog 

No Item Description 
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1 New column name Dynamic column name to be used in the Report. 

2 Metadata Optional. 

{ 

“version”: “1.2”, 

“name”: “AvgValues.prepvtjs”, 

“columnTooltip”: “Create column of averages for Obs M value(s), Obs m/z 
value(s), and ppm value(s)” 

} 

3 JavaScript code Contents of JavaScript. 

4 Available JavaScript Drop down at the bottom right contains all available JavaScript in the 
application preset directory which is typically Program Files > Protein 
Metrics > PMI Suite > Base > presets > [application] > [pre or post] 
pivot_script. Byos preset applies to all applications. For example, the drop 
down for Peptide Analysis Pre Pivot JavaScript including all *.prepvtjs files 
in the following directories: 

PMI-SuiteBasepresetsByologicprepivot_script 

PMI-SuiteBasepresetsByosprepivot_script 

5 Browse button Opens file browser to open custom JavaScript files 

Pre-Pivot JavaScript is formatted as:  

function (flatTableInput, columnName, arrayOfCustomColumn) 

 

Parameter Description 

flatTableInput Current input flat table. Contains all previously created pre pivot columns. 

columnName New column name. 

arrayOfCustomColumn Optional custom output column name if not using the new column name 
input field as the column name. 

An example that uses column name: 

function (flatTableInput, columnName) { 

for (var i = 0; i < flatTableInput.length; ++i) { 

flatTableInput[i][columnName] = i; 

} 

return flatTableInput; 

} 

An example that uses custom names: 

function ( 

   flatTableInput,  

   columnName,  

   arrayOfCustomColumn) { 

/** Column names that will be added to Flat Input Table */ 

   var avgObsM = ‘[Avg Obs. M]’; 

   var avgObsMZ = ‘[Avg Obs. m/z]’; 

   var avgPPM = ‘[Avg ppm]’; 

   arrayOfCustomColumn.push(avgObsM); 

   arrayOfCustomColumn.push(avgObsMZ); 

   arrayOfCustomColumn.push(avgPPM); 
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   return flatTableInput; 

} 

Post Pivot JavaScript is formatted as:  

function (postPivotTableInput, columnName, arrayOfCustomColumn, 

mapOfErrorColumnTypeNameAndColumnName) 

Parameter Description 

postPivotTableInput Current pivot table. Contains all previously created post 
pivot columns. 

columnName New column name. 

arrayOfCustomColumn Custom column names that will be in the Report. 

mapOfErrorColumnTypeName 

AndColumnName 

Optional parameter. 

Maps arrayOfCustomColumn to error column type 
name. 

For example, in AllErrorColumns.postpvtjs, AbsMax is 
mapped to error type error:abs:upper, and AbsMin to 
error:abs:lower: 

var arrayOfColumnNames = [“[Avg]”, “[AbsMax]”, 
“[AbsMin]”]; 

var arrayOfErrorType = [“error:abs:upper”, 
“error:abs:lower”]; 

mapOfErrorColumnTypeNameAndColumnName[ 

  arrayOfColumnNames[1]] = arrayOfErrorType[0]; 

mapOfErrorColumnTypeNameAndColumnName[ 

  arrayOfColumn 

Names[2]] = arrayOfErrorType[1]; 

Multi-Document Report 

Multi-document reports display the results of multiple projects within a single tabbed document. All reports 
must come from the same application type (for example, Peptide Analysis). To create a multi-document 
report, select File > Export > Generate Multi-document Report, then drag in the project files to include 
in the report: 
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Figure 116: Multi-document report input dialog 

Alternatively, click Add Row, double-click <Enter path to document>, click the  icon, then navigate to 
the directory and filename of the project to add. To remove a project from the list, select that project and 
click Remove Row. The Add Factor button creates custom factors and default values that can be added 
as fields associated with all projects: 

 

Figure 117: Add new factor column 

A factor represents an additional field that can be included to customize reports. For example, a factor can 
be run order, date, personnel, etc. 

The Report configuration path shows the file used as the default report template used. To use a different 
report template, click the Browse button, then navigate to the directory and filename of the report template 
to add. For details about the report template, see the Report Template and Default Report Template 
section.  

Existing report presets can be loaded for the multi-document report or saved for future reports. For more 
details about presets, see the Report File Menu section. 

Click Generate to create the merged report. 

Customize Report 

Contact support@proteinmetrics.com for information on a variety of existing and new report templates and 
dynamic columns. 

Up-to-date release and product information are listed on our website. Please visit: www.proteinmetrics.com 
and www.proteinmetrics.com/announcement/version-release-updates/. 

mailto:support@proteinmetrics.com
https://www.proteinmetrics.com/
https://www.proteinmetrics.com/announcement/version-release-updates/

